0 users browsing Discussion. | 1 guest | 2 bots  
    Main » Discussion » I still HATE smartdevices
    Pages: First Previous 7 8 9 10 11 12
    Posted on 21-11-24, 20:42

    Post: #1018 of 1041
    Since: 10-30-18

    Last post: 1 day
    Last view: 11 hours
    Successfully degoogled this junk phone, except for Maps... which can't even find where I am because the GPS on this thing is completely useless, even worse than the "sometimes you're here, and sometimes you're in Thailand" A-GPS on my now-defunct RAZR. Oh, and it lost its menu icon for no good reason at all...

    Veredict: no wonder why KaiOS is a failure: when you even fail to achieve basic phone functions (like non-braindamaged keyboard shortcuts, or doing ANYTHING AT ALL without getting stuck forever), noone will buy your shit. Well, nobody except masochists like me.

    Licensed Pirate® since 2006, 100% Buttcoin™-free, enemy of All Things JavaScript™
    Posted on 21-11-24, 22:53

    Post: #1019 of 1041
    Since: 10-30-18

    Last post: 1 day
    Last view: 11 hours
    OK, so this whole KaiOS jailbreak/rooting stuff is confusing, because just like the KaiOS market, the documentation is scattered in fragments here and there. Even the Bananahackers site is a mess, with duplicate/misleading uncurated information! But I think I've caught the gist of it:

    - OmniSD is an glorified app installer - it allows you to sideload apps from your SD card, without the need for WebIDE or a PC. IT DOES NOT ROOT YOUR PHONE!

    - Wallace Toolbox comes in a few flavors, but for Spreadtrum phones like the Zoey Smart, you need two pieces:
    1) The actual Wallace Toolbox from here, which allows to permanently enable the Developer menu without the need of a privileged reset (which will erase all your data), or having to visit a webpage from the (very fragile) browser "app" to enable/disable debugging! On the Zoey Smart YOU CAN'T USE THIS ONE FOR ROOT! (it doesn't work)
    2) A specific fork for Spreadtrum devices (buried somewhere at the Bananhackers website), which doesn't have the fancy menu, but it actually allows to TEMPORARILY ROOT (that is, you lose root at the next reboot) the bloody thing. You'll want to launch this one every time you need to enable root until the next reboot.
    So yeah... you want both.

    Even then, the amount of fun you can have is kinda limited. There is really not much to debloat here:
    - Google apps, including Assistant... that you will want to remove anyway because it doesn't even work anymore as Google crippled it after basically leaving KaiOS.
    - Twitter, which for some reason is not uninstallable on the stock ROM.
    - FakebookMeth webcrapps that you don't want to use anyway due to subpar UX and being mostly abandoned because this phone runs KaiOS 2.5 (which is already considered legacy). But amazingly you ARE allowed to uninstall those, no need to root!
    - A News app that only really works if you live in USA, India, or select parts of Asia. Which is really weird, considering that Blu targets Latam, not EMEA markets.
    - A stupid Horoscope crapp.
    - The Weather crapp, which loves to hang for no good reason at all, outside of being useless webshit.
    - KaiOS Pay... once I figure out how to uninstall hidden apps!

    As for what I think about KaiOS and the Blu Zoey Smart?

    Short version: STAY THE HELL AWAY. Buy a refurbished old Nokia, they still make clone batteries for those, and be happy.

    Long version: KaiOS is by far the WORST cellphone platform I've tried, EVER. This is a platform for dumbphones pretending to be smartphones, but it does nothing right! Bloaty, slow, buggy, half-baked, half-assed, "stateless", with a core featureset MUCH worse than anything Motorola/Nokia were releasing in the golden S40/RAZR era, 15 years ago! Man, my RAZRs, with puny single-core 200MHz ARM9 CPUs with 64MB RAM were far more responsibe, customizable, and useable than this garbage. And then, Blu came and took a bloaty platform which performed poorly on its 512MB RAM baseline... and shoehorned it on HALF the RAM - the result? Misery.

    Here's what's wrong with the $35 Zoey Smart, aside of, well, KaiOS:
    - 256MB RAM/512MB ROM. WTF BLU!!??!?!?!?!?
    - The GPS on this thing is either broken, or has marginal reception. No app is able to find out my location because this thing is not able to get a GPS fix - handy for paranoid nutters!
    - The FM radio has an internal antenna. Handy if you just need a table radio for emergencies, except when you're dealing with stations with marginal reception, where a twist of your headphones cable can make the difference on any other phone with FM radio!
    - The cameras are unusable garbage. Seriously, they still make VGA cameras in 2020, when this thing was made. WHY!?
    - SIM1 slot is ridiculously tight. You don't want to use micro/nanoSIM cards on their respective adapters on this slot, unless you want to risk damaging the cards, the slot, the phone, or your life. (Fortunately my Movistar SIM is one of their early 3G MiniSIMs, so no cuts or adapters at all!)
    - Oh man, the web browser (aka web browser within a web browser). It often refuses to load websites without any reason at all (which made enabling the Developer menu a pain), requiring to powercycle the phone. And even when you convince it to actually OPEN websites, it will gladly refuse to continue because the web is HTTPS nowadays, and this thing ships with an obsolete root cert database. Try opening Wikipedia: it will not continue because the issuer cert expired. Entering URLs on this phone is also a chore, and it's very slow to connect (there isn't even a "Loading..." animation of any kind. WTF, even 2004-vintage Openwave got this right!). Forget that this phone has a web browser, please.

    If the plan is to make dumbphones look as miserable as possible just to force people to buy smartphones, KaiOS and Blu fucking aced it. And sadly, the remaining platforms for dumbphones in the market (basically Mistaketek/Unicrud proprietary junk) are even worse. So yeah, better get a S40 Nokia, and only because BL-4C/5C clones still in production by countless Chinazi sweatshops!

    DON'T BUY THIS PHONE, or anything with KaiOS. Unless you're a masochist, like me. Even if you can root it, there is not that much fun you can have with it, the app ecosystem is crap (even J2ME is far superior to this webshit vomit). Hope it doesn't crap its pants at basic PHONE stuff, like calls (those seem to work fine?), or texts (it receives them, haven't tried sending those). Spend your $35 in drugs, prostitutes, alcohol, ammo, or anything but KaiOS!

    Licensed Pirate® since 2006, 100% Buttcoin™-free, enemy of All Things JavaScript™
    Posted on 21-11-24, 23:13

    Post: #1020 of 1041
    Since: 10-30-18

    Last post: 1 day
    Last view: 11 hours
    Just placed a phone call with the Zoey Smart.


    Voice quality is HORRIBLE, even considering the state of our mobile networks. The audio is too muffled, nearly unintelligible on the earpiece. HOW DO YOU EVEN FUCK UP THAT BADLY SUCH A BASIC FEATURE!??!?!?!?!?!

    I've used cheaper Chinesium 2G junk with far better audio quality than this thing. Ironically, the loudspeaker sounds much better :/

    Licensed Pirate® since 2006, 100% Buttcoin™-free, enemy of All Things JavaScript™
    Posted on 21-11-25, 02:28

    Post: #1021 of 1041
    Since: 10-30-18

    Last post: 1 day
    Last view: 11 hours
    6 hours with this phone, and I already want to commit arson and chemical warfare.

    Setup a custom ringtone:
    - On a classic Moto/Nokia: copy ringtone to phone, open the gallery, select the file, "Use/Apply as ringtone", done.
    - On modern Android: Depending on your phone OEM, it could be all the way from trivial to "install a file browser".
    - On KaiOS: Impossible, unless you install a very specific file manager just called "Explorer", and then you don't get a chance to preview whatever ringtone you're about to choose.

    The WiFi seems to be flaky too: sometimes the browser (which due to the Firefox OS heritage on KaiOS, is the ENTIRE PHONE UI) will refuse to load pages from the Internet, which causes all sorts of breakages on apps, from a web browser that does nothing when requested to load a page, to the KaiOS store getting stuck at 69% at startup. The workarounds are "reboot the phone" and "cycle WiFi OFF/ON". Pathetic. Oh, speaking of webshit, if one of those apps hangs or gets stuck in a endless loop or whatever, so does THE ENTIRE PHONE... leaving you with no option to pull out the battery, or if you're lucky and already had debug-enabled your device, adb reboot.

    Map apps are useless: the only one that works is Google Maps, except that without a working GPS, it's not that useful. Tried three different OpenStreetMap clients, and... ugh, all I got were bizarre network errors and getting stuck in UI loops where the only way out was to powercycle the phone.

    The more I use this phone, the more I regret my purchase. KaiOS is by far the WORST CELLPHONE PLATFORM I've ever had the disgrace of using! And I've used plenty of terribad phones, from early Korean camera phones (which were an UI/UX nightmare) to anything with Verizon firmware (back in the dark dumbphone ages, Verizon were the masters of lock down, disabling everything from custom ringtones to memory card slots to tethering in the name of greed). Looks like whoever designed KaiOS' UI either had never used a cellphone in its life, or hated cellphones so much that they devised the most diabolic plan ever to break the phone addiction: develop a cellphone platform SO BAD that people will get mad as soon as they power on their phone.

    Seriously, failing at very basic UI/UX features that even the cheapest and shittiest of dumbphones easily excelled 15 years ago requires actual effort to be THAT terrible. Unfortunately, my other options on the 3G dumbphone arena in the local market were equally unobtanium $30 Blu craptacular basement-tier Spreadasstrum/Unicrud 2003-spec 2G platforms with a 3G radio duct-taped on top (A120, Zoey Flip 3G)

    Licensed Pirate® since 2006, 100% Buttcoin™-free, enemy of All Things JavaScript™
    Posted on 21-11-25, 20:40 (revision 1)

    Post: #1022 of 1041
    Since: 10-30-18

    Last post: 1 day
    Last view: 11 hours
    More KusogeOS KrapOS KaiOS fail, Blu flavor:

    - Not only setting a custom ringtone requires the extra Explorer app, there is NO WAY to change the SMS ringtone from whatever default your specific OEM/telco have set, and this is why that in its infinite wisdom, KaiOS messaging app decided to use its own internal, UNCHANGEABLE ringtone instead of using whatever the user has set for notifications. I wish I were making this up, but god damn it, even my long-lost 2001-spec TDMA Nokia 3320 allowed to setup separate calling and SMS ringtones!!! WHAT THE FUCK IS WRONG WITH YOU, ASSHOLES!?!?! Haven't you ever used a cellphone!?

    - Since your phone UI is nothing but a big fat Gecko view, forget any semblance of multitasking. OK, most old true dumbphones couldn't multitask either (the best you could get was suspending J2ME midlets), but come on... with the botched handling of the END key on Blu's firmware, even singletasking gets annoying.

    - 256MB was overkill for cellphones 15 years ago (not even smartphones had that much), but KaiOS is a bloaty sluggish pig in such a modern starved setup. Conveniently, there is a Free Memory option on Blu's power button menu (what a weird place to put it) which plays a cute animation, and then displays an OK! checkbox. No way to actually tell how much RAM is free (this was a BUILT IN feature on BREW CDMA phones with the BREW App Manager, i.e. almost all of them!). And even the OK! screen doesn't give an obvious hint on what to do next (sometimes hitting END doesn't go back to the homescreen right away)

    - WiFi stalls a lot on this thing. If the "browser" refuses to open pages, or the KaiOS Store stalls at 69% on startup, go back to the homescreen, press UP, and toggle WiFi off-then-on there. I've seen this issue on Spreadasstrum phones which are about to die :/

    - Managed to get GPS working - turns out the GPS setup on this thing is very weak, so I had to go outside to let the phone actually find those satellites. Even then, Google Maps for KaiOS is more useless than the J2ME version, and all 3 apps that I tried for OSM ended doing nothing, or softlocking my phone. Yay. Not that I have any real use for GPS in my rather small city, but man... how do you even?!

    - Found a 2048 port (made by the KaiOS team) on the Store, since every cellphone, no matter how dumb or smart it is, needs some form of gaming for extreme emergencies, and 2048 is perfectly suited for pretty much every device that can run code and has a display and input peripherals. Wow, a 2048 version with a frickin' LOADING SCREEN. WTF is this, a 3DO!?

    - Of course, battery life is comparable to my shitty Alcatel, that is, miserable. I've done nothing but minimal webshit usage, a couple of test calls, and it's down to 53% since I had unplugged it from the charger this morning. FWIW, this thing has a 1000mAH battery, suspiciously similar to Nokia batteries of ye olde ages...

    - For whatever reason, the Google Maps app shortcut loses its icon, switching between it and a rocket icon (which I guess it's KaiOS' default) very often. Doesn't seem to happen with everything else (be it default, Store apps, or sideloads)

    - KaiOS 3.0 was released last September, but of course, in true industry fashion, the Zoey Smart is part of the family of phones already disowned by its OEM (mine was made in October 2020, but last firmware build is from late '19... and that's for KaiOS 2.5.1, which was long obsolete by then)

    - Did I mention that KaiOS 2.5 is based off Firefox 48? Yup, that means half of the Internet will give you scary warnings about expired root certs because half of the Internet is using Let's Encrypt, and sadly that means KaiOS just fell victim of The Great DST Root X3 Expiration. Android might not give a fuck, but FF (and by extension, KaiOS) do. And since there has never been a way to upload/update certs on dumbphones, well... we're fucked. Millions of cheap phones screaming in agony as their owners now need to add exceptions for nearly every site they visit. Yay.

    - Only the SIM1 slot takes MiniSIMs (the main reason I ended buying this phone instead of giving Movistar dealers $10 for a 4G triple-cut SIM). SIM2 slot takes MicroSIMs, but it's ridiculously tight - an old AT&T nanoSIM that came with my Alcatel on a Movistar micro->nano adapter had some trouble sliding in, but a Movilnet microSIM I borrowed for testing nearly ripped off the metal retainer on the slot! Be VERY careful swapping SIM cards on this thing. This seems to be very common on Blu (and other made-of-chinesium™) phones, so SIM slot failures on these cheapo PoS are not unheard of...

    Licensed Pirate® since 2006, 100% Buttcoin™-free, enemy of All Things JavaScript™
    Posted on 21-11-26, 02:41

    Post: #1023 of 1041
    Since: 10-30-18

    Last post: 1 day
    Last view: 11 hours
    Thankfully there is a solution for The Great DST Root X3 Expiration on our disowned B2G/KaiOS shitphones:

    You've got root, use it for good!

    Oh, found another stupid gotcha: if you set your default multimedia storage to the SD card (if your phone has one, and chances are it has given the paltry storage on phones like the Zoey Smart), Wallace Toolbox temporary root WILL NOT WORK! (at first it will appear to work, but you'll still not get rooted, and any successive attempt will fail with a NoModificationAllowedError). If you get stuck there like me, here is the fix:

    1) Delete tmpbin.bin from the root of the SD card. Don't use ADB (you don't have permissions there yet), instead use the File Manager app.
    2) Set the default multimedia storage to Internal memory (make sure to have at least 1MB free!): Settings->Storage->Default multimedia location
    3) Try rooting again. It should work this time
    4) When you're done, reboot your phone to un-root and set multimedia storage back to the SD card.
    5) Buy a refurbished late-gen S40 Nokia and forget that KaiOS ever existed

    Licensed Pirate® since 2006, 100% Buttcoin™-free, enemy of All Things JavaScript™
    Posted on 21-11-26, 18:49
    Post: #407 of 409
    Since: 10-30-18

    Last post: 37 days
    Last view: 10 hours
    Your desire to rant has greatly improved your english since you first started complaining about things here.

    AMD Ryzen 3700X | MSI Gamer Geforce 1070Ti 8GB | 16GB 3600MHz DDR4 RAM | ASUS Crosshair VIII Hero (WiFi) Motherboard | Windows 10 x64
    Posted on 21-11-26, 20:36

    Post: #1025 of 1041
    Since: 10-30-18

    Last post: 1 day
    Last view: 11 hours
    More annoyances of the Blu Zoey, which at this stage I consider a big mess with bits of cellphone scattered inside:

    - The FM radio has an internal antenna, which means you don't need headphones to tune in to the radio. So far, so good. Except that the internal antenna is tiny, which doesn't help with many local stations with weak signals, so you need to plug headphones. OK, no big deal, can't blame the phone for stations having low powered/defective transmitters. But then, while reception noticeably improves after plugging headphones, you're also forced to listen to the radio on the headphones, since there is no way to switch between headphones and internal speaker, unlike pretty much every other phone with FM radio tuner I've ever used - from my Alcatel to that ancient Nokia 6276 I still have on a drawer.

    - Speaking of weak signals, I don't know if I got a dud, or if all Spreadtrum/Unisuck cellphones have shitty WLAN chipsets, but WiFi is definitely broken on mine: it works for a couple minutes, then the phone stops sending/receiving data completely. Even ping fails with heavy packetloss... when the phone actually replies! The solution is to either powercycle the phone, or toggle WiFi off-on, then you get a few minutes of WiFi until it goes silent again. As I've said on earlier posts, last time I saw that on a Spreatrum-based phone, it was on that piece-of-shit Advance L4 from $AUNT that eventually died due to overheating. Since I didn't bought this for its so-called "smart" features, I'm not bothering to get the phone swapped/refunded, but damn... This also means that disabling the buggy broken WiFi greatly improves battery life on this thing, to the actual life expectations of a honest-to-God dumbphone.

    - Opening any website more complex than this board (particularly anything with many images) often causes low memory alerts from the phone.

    - According to Unisuck, the SC7731ef is a dumbphone platform for 3G networks, but there are many free-with-fries smartdevices with other SoCs of the same SC7731 family. It seems that the "ef" variant is exclusive for KaiOS devices, as it is only found on such phones so far. And then, most hackers basically only focus on Nokia/Alcatel phones, which use Qualcomm Snapdragon 2xx chipsets instead... So while in theory custom ROMs are possible for most (if not all) KaiOS phones, the reality is that unless you got a bananaphone (the Nokia 8110 4G), you should not bother.

    Licensed Pirate® since 2006, 100% Buttcoin™-free, enemy of All Things JavaScript™
    Posted on 21-11-27, 02:46 (revision 2)

    Post: #1026 of 1041
    Since: 10-30-18

    Last post: 1 day
    Last view: 11 hours
    How to do things on KaiOS, the KrapOS Way™:

    Change the SMS ringtone:
    - On any ordinary cellphone with not-braindamaged firmware: Look for your audio file, select it, Apply as Notification Ringtone, done.
    - On some cellphones with mild braindamage: copy ringtone to special folder using supasekret phone filesystem tools, reboot phone, apply ringtone as usual.
    - The KrapOS Way™: you need to root the phone and hack the SMS crapp, because fuck you, that's why!

    Change the homescreen shortcuts:
    - On any ordinary cellphone with not-braindamaged firmware: go to Settings, locate Homescreen settings, modify the shortcuts, done.
    - On some cellphones with mild braindamage: No OEM/telco was THAT evil, so the same instructions still apply.
    - The KrapOS Way™: you need to root the phone and hack the launcher crapp, because fuck you, that's why!

    Change the alarm clock sound:
    - On any ordinary cellphone with not-braindamaged firmware: If you can use your sound file as a ringtone, you can use it as an alarm sound too.
    - On some cellphones with mild braindamage: copy ringtone to special folder using supasekret phone filesystem tools, reboot phone, apply alarm sound as usual.
    - The KrapOS Way™: you need to root the phone and hack the clock crapp (and the implementation varies widely between OEMs!), because fuck you, that's why!

    Licensed Pirate® since 2006, 100% Buttcoin™-free, enemy of All Things JavaScript™
    Posted on 21-12-12, 22:48

    Post: #1030 of 1041
    Since: 10-30-18

    Last post: 1 day
    Last view: 11 hours
    If someone comes to you with a scAmazon Fire tablet demanding you to install Chrome just to get their bookmarks (because the lobotomized Chrome ripoff that ships with scAmazon advertising machines doesn't let you just import bookmarks from a file, LIKE AN ANIMAL FROM 1995), well, you're fucked.

    At least scAmazon now lets plebs install "dangerous 3rd-party" APKs on their crippled Android toys, and unfortunately there IS a way to let Google in on those:

    Please kill me now. Any Chrome install assisted by me feels like I'm commiting a terrorist act against the health of the Internet. Alas, you can't win against normies :/

    Licensed Pirate® since 2006, 100% Buttcoin™-free, enemy of All Things JavaScript™
    Posted on 22-01-20, 01:31 (revision 1)

    Post: #1039 of 1041
    Since: 10-30-18

    Last post: 1 day
    Last view: 11 hours
    So today I dipped my toes into the wonderful world of Modern™ mobile development...
    AKA "I tried to build my own .APK of this because Nintendo, despite the fact I hate cellphone games"

    Of course, I ended real pissed because this is modern software development.

    The instructions seemed real simple: setup an Android SDK build environment, drop your base ROM somewhere, then use Gradle to bulld your .APK. Simple, right? NOT!

    Setting up an Android development environment in Debian is easy, as all you need is on the repos: adb, android-sdk-platform-23, and since this thing wants an NDK too, google-android-ndk-installer. Except that the resulting environment is completely unusable! Here I go, in the same order as I got into each pitfall, what was the hell I had to traverse:

    - google-android-ndk-installer is just a shell script that will download a NDK from Google... which is a 1GB download, which takes over 1 hour on my 3MB DSL, if the stars align.

    - Invoking ./gradlew will die real fast because ANDROID_SDK_ROOT wasn't defined. OK, point that to /usr/lib/android-sdk.

    - Invoking ./gradlew again start downloading some stuff (like Maven and... ugh, Node.JS), just to die because I haven't accepted the licenses because lawyers have to justify their slimy existences. The naive approach would be to run sdkmanager --licenses --oops, that's in a separate Debian package. And it won't work anyway because...

    - ...$ANDROID_SDK_ROOT points to a read-only directory, and Gradle will try to download new SDKs because the Debian ones are too old anyway! Except that it somehow wants a standard directory layout or some shit, so your options are:
    1) chmod -R you:you /usr/lib/android-sdk. Ugh.
    2) Run Gradle as root. WHY!?
    3) Forget about the Debian SDKs and go to Google, logon (because of fucking course they now force you to logon just to access the developer resources), and download a SDK and unzip it somewhere else, then point ANDROID_SDK_ROOT there. Not happening!

    - After shitting on proper Unix hygiene rules and giving Gradle access to a chunk of your /usr, run ./gradlew again... which will gladly download another 2GB of SDKs, just because that's how modern software development is done! You Simply Do Not Install SDKs And Go in these brave new times :/

    - Finally, after 4 hours of endless donwloads, mostly useless Stack Overflow posts, broken Debian guides, and JavaScript Frat Boys blogspam, you'll get your highly coveted SM64 debug .APK that Nintendo will never give to you (at most, in a parallel world where Nintendo starts selling classic games for cellphones, you're getting a $20 ROM wrapped into a really bad emulator)

    - Oh, you wanted a RELEASE .APK? (why? I don't know, but it weights 2MB less than the debug one, FWIW) Cool, you can build one... that your cellphone will refuse installing with an INSTALL_PARSE_FAILED_NO_CERTIFICATES error because of fucking course you don't have a release cert store and haven't bothered setting up your project to use one. Forget about that crap, read this and this, and manually sign your APK.

    - Wipe your HDD/SSD and burn your cellphone.

    Man, this was HORRIBLE. Debian has an unusable Android development setup out of the box (no surprises there). Android development environments are tied to a working Internet connection for no fucking good reason at all (once again, no surprises there). Building a trivial cellphone app requires downloading gigabytes of junk. And of course, documentation is broken and you're at the mercy of StackOverflow posts and blogspam just to reach the goal. Contrast with my previous adventures with J2ME a decade ago or so, where all you needed was to install NetBeans + the J2ME SDK plugin, and go. No Internet needed AT ALL!

    Ah, and Super Mario 64 looks awesome on a cellphone (and it runs smooth as butter on my lowly Snapdragon 210). And it's completely unplayable with those awful touch controls! I gave up after spending 20 minutes to reach the top of Bob-omb Battlefield, because trying to grab King Bob-omb with a touchscreen would have been a easy way to destroy my cellphone. I reiterate: action videogames DO NOT belong to cellphones! Stick to card and puzzle games.

    I'm glad I don't earn a living making cellphone apps, otherwise I would have ended dead/in jail years ago :)

    Licensed Pirate® since 2006, 100% Buttcoin™-free, enemy of All Things JavaScript™
    Posted on 22-01-20, 09:43 (revision 1)

    Post: #382 of 382
    Since: 10-29-18

    Last post: 2 days
    Last view: 2 hours
    Posted by tomman
    action videogames DO NOT belong to cellphones!

    That's when you connect your Bluetooth game controller.

    I did that with a GameSir G3s when I was playing around with emulators on my phone.

    My current setup: Super Famicom ("2/1/3" SNS-CPU-1CHIP-02) → SCART → OSSC → StarTech USB3HDCAP → AmaRecTV 3.10
    Posted on 22-01-21, 18:24

    Post: #1041 of 1041
    Since: 10-30-18

    Last post: 1 day
    Last view: 11 hours
    In less sucky (but still sucky) phone gaming adventures, KrapOS™ can actually run Doom!

    Too bad playability is not great:

    - Unless you have the one KaiOS phone with a portrait screen (because it's the one device that also has a QWERTY keyboard), you'll be forced to play with your phone sideways, which is very awkward, to say the least. But hey, at least you get PHYSICAL KEYS!

    - No music, because MIDI synthesis would be too much for the weak CPUs and ancient Firefox versions of those devices, dropping framerates to "frames per MINUTE" levels.

    - Lag is the name of the game (particularly with shit phones like my Zoey Smart), and this is particularly noticeable with sound effects. YMMV if you own a less shitty phone.

    - 256MB RAM devices can only run the built-in FreeDoom WAD and the Doom shareware WAD. The app will bomb out when trying to import retail Doom I/II WADs due to Gecko OOM'ing - amazingly the phone will NOT crash/reboot/halt and catch fire, instead you'll be kicked out to the homescreen.

    I've seen Doom running on even more miserable hardware, though, so at least KrapOS™ doesn't get a zero here.

    Licensed Pirate® since 2006, 100% Buttcoin™-free, enemy of All Things JavaScript™
    Pages: First Previous 7 8 9 10 11 12
      Main » Discussion » I still HATE smartdevices
      Kawa's Github