Problem with SCI Studio template game

Kevin Coyle I'm having a problem while trying to create a new game using the templete. Everything works great when I create a blank game or load one of the sierra originals, but when I try to load the template game or use the option to create a new game using the template I get an error message, then my computer crashes and I get another message saying my system is dangerously low on system resources and I pretty much can't do anything at that point but cut the power to my computer.
Kevin Coyle Actually, it also crashed when I loaded King's Quest 1 SCI.

I ran the resource meter on my computer and I had 92% System Resource available before running SCI studio, 91% when SCI studio was running then when I loaded KQ1 it crashed saying I was dangerously low on resources.

Also I think I should mention every time I run SCI studio, it asks me to go through the setup process first.
Kevin Coyle If it's any help, I'm running a Gateway 1Ghz Pentium III with 256 meg ram.
AGI1122 Just click the checkbox that says show welcome so that it is no longer checked. Then it won't go threw the setup process.

As for the resource problem... I get it too. SCI Studio seems to waste alot of system resources. At one point my system was so low on resources I couldn't open a text file that only had 3 lines in it. It said to close some program... but I didn't have anything open. :P
SCI Studio seems to waste alot of system resources.
With what computers are you guys running SCI Studio on? I don't think SCI Studio is hogging any resources. About 15 megs of ram, processor usage is also very low in use (I am running P3@800 with 512 megs RAM). Are you using win9x? This could be the reason, win9x/winme have very poor memory-management.
AGI1122 Win98... but SCI Studio is the only program I have had memory problems with... which means it has to have something to do with SCI Studio.
PetriSimolin Have you ever tried to run any memory-defragmenters?

In my understanding, winnt-based operating systems do this own their own (and handle memory much more wisely in other aspects also), but win9x/winme does not handle memory-fragmentation very well.

Maybe you should try running some memory-defragmenter once in a while, when using SCI Studio?

(I don't know if those programs really work, just suggesting)
Omer Mor Win9x has a fixed amount of resources (handles, brushes, pens, etc..) no matter how much memory you have.
WinNT allocates resources dynamically.
scistudio might be leaking resources that don't take too much memory, but in win9x it can be fatal, because the os can't allocate new memory for resources.
Brian_Provinciano King's Quest I SCI is SCI01, so it's not officially supported by SCI Studio. Quest for Glory II (SCI01) definately will crash it.

As for the template hogging things, does it crash you just by loading, or are you doing a lot of stuff before it crashes?

SCI Studio loads all the SCI map and file information into memory in ListViews, which will take up memory. However, due to current computers and Virtual Memory, they really shouldn't be a problem. You running 1ghz puzzles me, as I've run it on pentium computers with 16 mb of ram.

Does it do the same thing on a clean system boot and clean load of the template?
AGI1122 It justs happens randomly... the longer you have SCI Studio open it keeps leaking resources. I was working in the script editor and it lost so much resources while I was working that the fonts in SCI Studio shut down and everything looked funny(I am not talking about SCI Font resources, I am talking about the font throughout the studio).
Kevin Coyle I'm running Window's ME

My problem occurs while I load the template game, when the loading progress bar reaches 100% the error occurs. This even occurs after a fresh reboot.

I'm going to try SCI Studio on my other computer to see if it works any better

AGI1122 Make sure game.bmp game.txt and game.ini are in the directory with the template... when I removed 1 of them it crashed on me when loading too. Then I put it back and it loaded it.
Brian_Provinciano That's very odd. I tried deleting each of the files one by one, then some together, then all of them, and SCI Studio didn't come with any error.

I've been building in on XP, which a lot more stable, so that would explain things. However, I have tested it on Windows95 and 98, and everything worked fine. To top it off, I didn't just test it out at home, but also at school and elsewhere.

I'm thinking I might need to redesign the resource table system, making it not load all the resource info up at once. It would be a lot of work and make SCI Studio slower though.

My main concern is that it better not have to do with the script editor's edit control, as it was written by SynEdit. If it has problems, I wouldn't know where to start. It contains a massive amount of code.

I've been working on adding some suggested features: multiple undos, the ability to select a region to cut, copy, paste and drag in the view, font and cursor editors, and so forth. I guess I'll move on to the bug fixes though.

On another note, when SCI Studio loads, it only takes up 5mb of memory (which is still a fair amount IMO). When I load the template, it takes up 8mb. This is really only due to all the controls, buttons, list views, etc. It doesn't even load the whole game, just the 1KB map, and some resource info from the packages (about another 1KB). The unfortunate thing is that Borland ignores memory limitations and bloats everything with junk. If I had started from scratch, I probably wouldn't have used Borland C++Builder, but since it's got over three years of work in it, I'm not going to rewrite it in something else.

There are a number of times when I've come across Borland bugs and need to work around them. It gives me serious headaches. Aw well. I guess no compiler is perfect.
Kevin Coyle It seems to work well enough on my other computer (500mgz, 192 meg ram, win98) so at least I can use it on that one

I haven't done much with it yet but it looks really good so far, Nice work! It's good that you took the time to provide tutorials to go along with it.

I currently working on an AGI game I started last spring, but kind of got away from for a while, I'm working on it again now and plan to make the sequal in SCI Studio.
Omer Mor Brian,
I was wondering: why do consider KQ1 as an SCI01 game?
I saw it written on various places, but I can't figure what makes it an SCI01 game.
I know it works fine with Ravi's drivers for SCI0, and it also has the typical SCI0 debug mode enabled.
Brian_Provinciano If you'll check it's version, it's an SCI 1.000 game. It supports new compression methods, as well as digital sound effects.
Omer Mor well, my game has this version: "S.old.010".
From some aspects it is compatible with SCI0:
graphics: 16 color EGA.
sound: it can use Ravi GM driver for SCI0, which SCI01 games can't use.
interpreter: it can't use sci01 interpreters from qfg2 and christmas card 256, and it also can't use interpreters from early SCI1 games like sq4, jones, etc..

on the other hand,
it also can't use interpreters from late SCI0 games like conquest of camelot.

so I guess this game is a weird hybrid, don't you think?
Brian_Provinciano It seems that all SCI01 interpreters are different and incompatible, while most SCI0 interpreters (other than the really early ones) are compatible. Due to SCI01 being of obscure versions, and SCI Studio being for making games and not editing them, I'm not going to bother supporting them. I will be moving right to SCI1 VGA when the SCI0 SCI Studio is settled in and fully stable.
Omer Mor I was asking from curiosity, not because I expect SCI Studio to support it...
I'm just intersted in the evolution of the SCI interpreters, and their compatiblity with each other.
That's all...
juncmodule I noticed something about people with errors. We are all running big processors. I have an AMD 1.5ghz with 256MB of DDR ram and SCI studio and the template game both lock up my system (template game immediately, SCI studio only when I open a game.) I'm still trying a few things, I think it is something wrong with my computer and not SCI Studio or SCI games. If anyone knows of any conflicts with my setup.... Previous versions have always run well on my laptop (which is only 166mhz with 100MB of RAM) Is there something about the new version that would change things? If I find a solution to my problem I will post it so that hopefully it will solve others problems as well.