The parameter is incorrect...Help!

IAmError Being a newbie to the SCI Studio I was amazed to find out how easy it was to use the program. However, I seem to be getting an error while using the Picture Editor... The error "The parameter is incorrect" appears in a standard error box with a red circle and a white X inside it, and it happens as I'm scrolling back and forth through either a pre-exsisting picture from a game, or a picture that I've drawn and are currently drawing. I have to close the program to be able to continue using Windows(causes graphics to disappear inside Windows) or SCI Studio. I've tried new and old versions of SCI Studio, and I still get the error. I've tried it on two different computers and the error still happens. Thanks for any help.
Robin_Gravel Hi IAmError

Welcome to the messageboard.

Are you using win98 or xp?

Robin Gravel
IAmError The two computers(Home and Work) I've tried it on are both Win98. I was thinking of trying WinXP... I guess I'll have to for testing purposes. I'll get back to you on this. thanks
IAmError Well, I gave Windows XP Pro a shot with the latest version of SCI Studio. It didn't produce the same error, but a different one appeared, "Not enough storage is available to process this command." and it's while doing the same thing in the Picture Editor ???
Robin_Gravel I am using win98.

Win XP has bad reputation to not running old games (both dos and win95) so I don't with to upgrate my computer to win98.

I also get an error when using pic editor but it's not too bad.

Be sure you save your background after a while (about each 2-5 minutes) when you're using pic editor.

Robin Gravel
IAmError I guess it's a bug in the program... :( I'll have to make do and save soon and save often. Perhaps in a new version this might be addressed (Hoping the creator is watching) ;D heh. Thanks for your help Robin.
cloudee1 Yes it is a common problem, Brian has addressed it stating more or less that everything would be have to be rewritten, something about it leaking memory like mad. since these problems primarily occur with win98 and aren't quite so frequent with XP I would strongly suggest trying to use that.

I don't know if the new SCIstudio will have this same bug, I don't think anyone has ever said but since it is an extension of the current studio I would probably say yes.

If you can find it Nychold has reworked scistudio somewhat to suuposedly fix this, I haven't tried it so I don't really know. Somewhere around here, one of these threads, Nychold mentions it and I think there's a link but I don't know where the thread is right now so I'll let you search for it. ;D

p.s. with xp often times when getting that error you mentioned, you still have an opportunity to save your game. As you will notice when you click on ok nothing happens until you click something else, make that something else the save button and that crash ain't quite so bad.

p.s.s the cascading error, the one that doesn't stop, it sucks. :-\
Nychold I haven't had the chance to test it, since I don't own a copy of Windows 95/98 anymore. I'm using only Windows 2000/XP, so I'm not sure if it works. I'd love for people to test it, and let me know. :)

Modified SCI Studio

PS: I did have some conversion problems between compilers (Brian used Borland C++ Builder 5, I use Borland C++ Builder 6), so if anything else is broken let me know. :D