Conquest of the Longbow error

Kon-Tiki I got to the point where Marian's attacked by a monk on day 2 in Conquest of the Longbow. I shot the guy, but then the game closes, giving me an "Out of handles" error... anybody knows what this means?
cloudee1 It means that you need to use dosbox to get passed this point.

save your game just prior to shooting, exit and load game with dosbox, restore shoot him and resave, exit game and then just restore.

p.s. while using dosbox the game will play very very slowly but it shouldn't crash when you shoot the lowlife scum for jacking with your woman
Kon-Tiki DosBox crashes my comp, unless I disallow the mouse to work in it ::)
rwfromxenon I got a bug after I picked up the pixie. He'd make me follow him to the north, but Robin just gets stuck there.
I'd like to finish the game, but I don't know how to get around this.

EDIT: Ah, never mind. I just went to the screen west of the tree, and it fixed it.
Kon-Tiki wrote:

... disallow the mouse to work in it ::)


it will only take a moment, as soon as you see that new frame save and exit.
Kon-Tiki Got past it. Seems like the crashing's less if I put the autolock off, but it still crashes regularly on irregular tries to start it up. After that, I can put the lock on with Ctrl-F10. Anyways, got past it, but CotL does still crash on random moments ::) Also got the sound to work. Tried the Roland-thingy in settings for music. Sound itself's not working, but at least I have music. Strange music... but music.
cloudee1 I've said it before and i'll say it again, to get sierra's sounds to work I like VDMSound. There's no weird commands or load screen just right-click and run.

rwfromxenon VDMSound doesn't always work. I am, and always will be, a DosBox man. Just twiddle with those settings and the function keys. :)
Allen wrote:

VDMSound doesn't always work. (...)

Like here. It doesn't work at all.
The Ultimo You should download Abandon Loader to play it. I used it to play most Sierra games and Lucasarts game when I had XP on my PC, and it worked fine, with sound and mouse support.

I would give the link, but I couldn't find it after a quick search. Just try google, and see if you can find it.
cloudee1 vdm works with my quest of longbow, I installed as adlib sound driver (which I don't have) and the music and sounds work fine. There's an error created by sciv which states it doesn't work, but it does.