AGI Studio Problems

Azwald Hey. I've been having some problems with AGI Studio (old /and/ new). The first program occurs in both the old version and the new version. When I try to make a new game, no matter where it is it says the directory is invalid. I can fix this by copying the template folder to another directory and opening that file. From there I can edit it, but when I edit logic files it says it can't write to the directory. And the other problem happens in the new version only. It was running fine yesterday, but today I ran it and got :
AppName: agistudio.exe    AppVer:    ModName: kernel32.dll
ModVer: 5.1.2600.0    Offset: 0000d756

I am using Windows XP Home edition, if that helps any. Thanks for any help you can give me in advance. :)
AGI1122 Well first of all... AGI Studo can't put the template to a directory such as c:\game\ it has to be something sort of like c:\game\game\ I don't know why it does this. So make sure your folder isn't located ina folder that is directly in your hard drive but rather make it a subdirectory. As for the not saving logics part see if the above fixes it... but if not use the new version and it should fix any logic saving/compiling problems.

As for the kernel32.dll problem, I never heard of this problem before. Try restarting your pc and then try to use it again.
Azwald Still no success. The subdirectory thing still gives me the Invalid Directory message, and restarting my computer doesn't help the new version. *chuckles* Compatibility mode doesn't do anything. Oh well. I thought I would give it a try. Anyway, thanks for the help.
AGI1122 I remember some time ago hearing about someone distributing a copy of the template that had write protection on the template. This might be the case. I would try downloading and using a different template and see if it fixes it. There is one that is more advanced than the one included with AGI Studio at my site which is in my signature. Try using that and see if it still gives off the error messages.
sonneveld To help the program to run:

Try renaming the agistudio.ini file to something else and see if AGI Studio works then? If so, send the ini file over to Nailhead so he can see what the problem was.

- Nick
Azwald Well, I'm pretty sure both problems have to do with this computer. The old and the new AGI Studios both work on my other computer (running Windows 98)... Just another reason to hate Windows XP. ;)
Randy I've had this problem too with XP. For me, it looked like the program would add a "/" to the root folder in which to save. XP, however, seems to add the trailing "/" too. So the invalid folder is referring to the full path with double "/" in them.


I couldn't get around it so I am currently using my old Win98 machine to make my games.
sonneveld Azwald: will this affect the progress on your game?

- Nick
Azwald Well, I haven't really started to make a game yet. I have mostly been experimenting with the language and picedit and such.
Rut I have the same directory problem on home xp
AGI1122 Hey Eric, maybe you should make a way to detect win xp and then if they are using xp don't add the extra slash.
Joel if it's a matter of AGI Studio adding a backslash, then there doesn't need to be a mechanism to detect WinXP. All that needs to be done is to check if the backslash is already there.
happyturk2 If it helps narrow it down a bit, I'm on a WinXP Professional box, and I've had no problems. Might have something to do with all the funny limitations/restrictions they put on the Home edition, seeing as they're slowly working at phasing in the dot-net system, limiting the functionality of unauthorized and individually-written programs(as opposed to those -they- wrote) to run on their systems.

Just a thought.
Nailhead Never fear! I'm releasing v.1.36 tonight and it fixes this bug (I think) so that you don't have to wait any longer to start working on your game. I'll post a new topic when it's ready.