something really crappy just happened

doan sephim i was working on my game and i went to rebuild the resources or know that button that reduces the game size. well i did that and SCI Studio informed me that some rare problem occured and it closed out my game. i tried to reload it, but it said that it was unable to on account of it not being complete, or the wrong version and all that. it told me that it was unable to do it because "resource.001" was messed up. so i checked the folder and it was missing (really replaced by a new temporary file called respak.tmp. i attempted to copy and paste a new resource.001 file into the folder, but sci studio told me that if was not of the same game and wouldnt open the game.
im working on XP, does anyone have any idea what happened? really all i want to be able to do is salvage the views, pics, and that possible? any ideas extremely upset about this!
Eigen I've had the same problem when rebuilding. But then it kept the resource.001, it was just corrupted.

But you could try this,

It's for recovering corrupted SCI games.

doan sephim thanks eigen...but my resource.001 is no longer there (seems to have been replaced with respak.tmp), so the couldnt and didnt do anything without it, unless i am using it wrongly. the respakl.tmp is a file that i cannot make heads or tails of either...what is it?
what exactly is resource.001 and what is its function? why is it that without it i cannot seem to do anything with any of my other files in that game?
doan :'(
Eigen Could you send it to me? It would be easier to try to get it to work.

edit: resource.001 is the place where all the pics, scripts, views, sounds and stuff is being kept. In one big file.

doan sephim just in case anyone has a similar problem, eigen figured out a way to restore my game to working condition.
first he renamed the file that replaced resource.001:
1. from "respak.tmp" to "resource.001"
then he:
2. deleted the "" file
and then
3. used this program
to rebuild the game.
it worked perfectly.
FastaKilla same thing happened to me;action=display;threadid=3416