Serious DQ2 problem

Joey wtf is this. i was editing the logic in agi studio on dq2, then when i went to compile it, it came up and said error accessing vol file. so i got out and when i went to open up the game it gave me this message:

Either there was an error reading one or more files, or this directory does not contain a valid AGI version 2 or 3 game.

IT WAS JUST WORKING A FEW MINUTES AGO! Jesus. What happened and how can I fix it? (luckily I backed it up but I dont feel like doing all the changes since the last back up all over again.)
Joel (not logged in) are you running a 9x version of Windows. and did you close down the game through Windows instead of through the game menu? did you try to compile while the game was running?

if you did the first thing, just restart your computer and it should work fine. if you did the second, just shut down the game. the only other thing I can think of that might not be a serious problem is for you to make sure that the read-only attribute is not set on the files.
Joey i have in 98 and i restarted the computer then tried compiling and it worked. then i made a change and compiled and it happened again. oh well ill just restart again and see what happens. thanks joel.
Kon-Tiki It's as Joel said. Just close the game when compiling it. Had that problem a few times too, and only when I forgot to close the game.