Stack blown error

Joel (not logged in) I have encountered a problem in my work on Jen's Quest. There is a certain screen of mine that works fine on my home computer, running Windows 98 SE. When I bring it to a computer running Windows XP Home Edition, the same screen gives me a stack blown error. I already looked at the stack blown tutorial on The screen in question does have a pretty good amount of brush work, but I already made sure that I did the fill command underneath it first. Any ideas what might be causing this?
sonneveld I reckon it's a software interupt that windows probably uses as a dos mouse driver (or some other device) that uses up a bit too much stack before returning.

Have you tried saving the pic at different stages of the drawing process? see which fill puts windows xp over the edge?

The only other recommendation i can think of is to use the stack patch.

One point to mention, it's not the brushes that are causing the stack overflow directly, but filling around the edges of the brush pushes a lot of data on the stack. Perhaps make your brush patterns more dense?

- Nick
Joel I'll try saving at different stages of the picture. Unfortunately, I don't have access to an XP computer at home, so it will have to wait.

I was actually thinking about going in and making the brushing less dense, because it's already pretty thick. But, like I said, I always do fills before using the brush tool. Beyond the possibility for the stack error, it's also pretty tedious trying to fill around brush work.
sonneveld another suggestion is for large fills, split the area with a single line of the same colour and replace it with two fills.

- Nick
Joel it actually looks like there was a problem occurring on my Win98SE computer, a much more subtle and much worse-looking problem. Seems that when I tp'ed to the screen in question (only way to access it right now) and then tp'ed to the inside screen of charles' and clarissa's house, Windows would give a message saying that the program performed an illegal operation and that I should restart my computer.

I went back to the pic resource and did like you suggested, putting lines between the fills, and the problem seems to have disappeared. I'll still have to wait until I get access to an XP computer again to test it, but it looks like it might be solved.
Andrew_Baker Yar, that tp could also add to your trouble if you didn't get that fix (I think Cromer or Sonneveld did it) published in this forum a wee while back. Seems that the tp command forgot to deallocate memory from the stack, which meant that repeated tp'ing or tp'ing into a memory-hungry screen would cause the interpreter to poop its pants.
Joel Oh, yeah. I remember that problem. If I'm not mistaken, the problem was actually introduced into the template game when it was updated to have the convenient debug menu and all that stuff. Jen's Quest is based off an older version of the template game and never had that bug.

I kind of narrowed it down to the problematic screen, because at first it seemed to be happening after a lot of tp's, because I could tp all over the place without problems, then when tp'ing to the inside of the house the game would crash. Then after a couple times I noticed that I had tp'ed to one particular section of the game before the crash and then I tried tp'ing just to that one screen which gave the stack blown error under xp and then to the inside of the house and the game crashed immediately. I haven't had a crash since I changed the pic resource, so it seems that that was the problem.
Joel Yeah, I hope I don't have that problem since it was actually me who posted the fix :);action=display;threadid=1733;start=0
Andrew_Baker I stand corrected :D