AGI Studio v1.34 released

Nailhead Ok it's been a while but here's a new release. Enjoy!

Version 1.34 (02/25/2002):
  • Updated the Help file (by Chris Cromer)
  • Updated Template game (by Chris Cromer)
  • Updated the 'Web' menu
  • Added shortcut keys for 'indent' & 'outdent'
  • indent=TAB outdent=Shift+TAB
  • Added 'Open' to the resource window context menu
  • Added an animate feature to the View Preview window with speed select
  • Added LOTS of logic editor options under SETTINGS | ADVANCED EDITOR OPTIONS
  • Renamed the unknown commands
  • unknown170 > set.simple
  • unknown171 > push.script
  • unknown172 > pop.script
  • unknown173 > hold.key
  • unknown174 > set.pri.base
  • unknown175 > discard.sound
  • unknown176 > hide.mouse
  • unknown177 >
  • unknown178 > show.mouse
  • unknown179 > fence.mouse
  • unknown180 > mouse.posn
  • unknown181 > release.key
  • AGI1122 Yeah this should be great I am getting it now. :D

    Good job.
    eidolon Goody, goody!

    But forgive me for asking; what about unknown182() ?
    AGI1122 I don't beleive 182 was in the pc version of the interpreter. That would explain the reason it is not in AGI Studio since most of it is based on the pc version.
    AGI1122 Hey Nailhead just thought I would mention that the splash screen still says 1.33 instead of 1.34.
    Joel It looks like you've done a lot of cool stuff with this new version. Unfortunately, I can't test it all out. When I open up the logic editor settings and change from the General tab to the Display tab, my computer locks up (I tried several times, twice with a game open and once without -- the first time I had changed a setting in the general tab the next two times I hadn't).

    Yeh, that's an amiga command.   I wouldn't mind it for when i edit amiga games.

    - Nick
    AGI1122 This is great I love the view animator. The view animator does have one bug that I noticed. It starts at cel 0 goes to the last cel then it instead of going back to cel 0 it goes to cel 1.
    Nailhead Joel, the only thing that goes on in that tab is a combobox is filled with your installed fonts. I've limited it to only TrueType fonts so maybe it won't crash now? The default font is set to 'Courier New', if that font is not installed on your machine it may crash (but everyone who is running Windows should have it). I've fixed the splash screen too. I'm looking into why the animator isn't resetting to cel 0 also.

    I've reuploaded the current version with these changes. Let me know if that fixes it, and if it doesn't I'll just disable that control all together.
    Joel No, I downloaded it again and it still locks up. I definitely do have Courier New installed on my computer. I use it in all the (many) other programming tools I've got installed on my computer. I can tell you that the problem is definitely localized in that one tab, though, because I can switch between the syntax color and the general tab without any problems (also, a little more info: it doesn't matter whether the AGI Studio window is maximized or not; it also doesn't matter whether I go to that tab from the general tab or the syntax color tab).

    I think the view animator is cool, too, although I could use a slightly bigger speed control. It's really small at 1024x768.
    Joel There appear to be some bugs in the view animator, too (it actually might just be one bug)...aside from the looping back to cel 1, I'm also getting playback beyond the last cel.

    For my ego walking animation, loops 0 and 1 play fine (each has 8 cels), but loops 2 and 3 have only 6 cels but they play through to 8 cels. Also, another view with a death scene I had played through the maximum cel number of 12 to cel two hundred and something.
    AGI1122 I had a problem with the view animator also. I tried it on one of the big space ships in V. The animator went crazy showing loops blurring them and mixing them.

    Also in the advanced settings on the general tab the smart tab box does not work. Every time I click it the box never has a check in it.
    Andrew Baker The loop animator only seems to go beyond the max cel number if the other loops in that view have a higher cel count than the loop currently previewed.  (E.G., if Roger Wilco walking left is 8 cels long, and Roger walking forward is 6 cels long, then the loop animator will make walking forward 8 cels and will show a cropped image of earlier cels to fill in the 'missing' cels 7 and 8.)
    Joel I can reproduceably get the cel number to go up and up without limit on certain views. I've also run into another oddity where the animator wouldn't play all the way through one animation. It cycles back to cel 1 after 6 of 9.
    Nailhead Thanks everyone for your input, this is helping me figure this thing out. One day I'll fully understand Peter's code.  :-/