Inventory Corruption

sonneveld I'm not quite sure of the answer to this yet, so I set up a separate topic:

I'm using the Template game running off the Space Quest II executable, and I'm having trouble.  When I pick up certain items, the inventory screen displays a whole bunch of garbage characters.  Is this a common problem?

sonneveld AGI Studio has an object file editor to define the names of the objects.  Are you picking up objects that don't have a defined name?  (ie, picking up object 10, but you've only defined 9 names)

Older versions of object files were not encrypted.. but that can't be the problem because you say that you can read some of the text.

- Nick
AGI Studio has an object file editor to define the names of the objects.  Are you picking up objects that don't have a defined name?  (ie, picking up object 10, but you've only defined 9 names)
I don't beleive this could be this could be the problem because the only way to have less objects than defined would be to delete one. But the logics would give out errors when compiles. And also I beleive the interpreter would probably give out an error too.

I am not too sure of what the problem is either. Maybe he could tell us some more about it so I might figure out what is wrong.
Andrew Baker I was giving the ego inventory items that had descriptions in their views with {get("mushroom");} not specifying an object number.  The compiler didn't give me an error message.  I went into Object editor and defined an object called "mushroom".  That seems to have fixed it.  I think part of the problem may have been due to my interpreter causing some weird bugs to occur when I "restore" a game as well.

smartguy240 ;D I have figured out the Inventory Bug ! ;D or in my case at least... I opened up the object editor in AGI STUDIO ver 1.35, and clicked on OPTIONS. There is a list of 1 thing that says something about encryption. I clicked it so that it was OFF and my inventory is normal!!! SMG240 ;)
sonneveld I think this means you're running an older version of the intepreter. Older versions don't use encrypted object. SQ2 does though.

- Nick
smartguy240 Actually, you are very correct. I started fooling around with AGI programing in 1999. I got frustrated, and I stopped. All that I could do was change game messages on some AGI games that I had ;D . But then I got into programming in general, and said, there has got to be some way that I can figure out this AGI pragramming stuff. So I got AGI STUDIO 1.35 and noticed the compiler. I was like WOW... no wonder I couldnt understand how to fix my errors on what I was doing in 1999. SO I researched AGI Programming and here I am today!

The template that I used was the template from Peter Kelly's AGI STUDIO ver 1.30. So that is why it was so old!

;D SMG240 ;)
AGI1122 Well I would download the newest template then... I have one that is alot more advanced than the one that Peter distributed it. You can download it at in the utilites section. :)
smartguy240 Well, If that is the template that came with AGI STUDIO 1.35, i already have it. BUT, I tried to convert my game too that template, and I can not start my game. I get a message that tells me to enter disc one!

AGI1122 Yeah Nailhead did include my template with the latest versions of AGI Studio. :)

But I don't understand why your problem might be happening... maybe Nick might know?
smartguy240 It was because i had sound resources loaded on the old template, and they still had the load.sound command on them for the title page! But now I get a message that says discard.view(42) cannot because view is not loaded or something. I DONT EVEN HAVE A VIEW 42!!!! >:( ... oh, well....

AGI1122 Well somewhere along the line in your game the command discard.view(42); must exist. You should search around for it and remove it.