New utility: AGI to SCI view converter

Mokalus_of_Borg I've just uploaded the first release version of VEW2VEW, my AGI to SCI view converter, to my website here. It took much longer than I thought it would, but now it's done.
Currently, mirroring is done with a fresh copy of all the cels, and I plan to update the program later to handle it "properly".

Mokalus of Borg

PS - Once again, this may be more interesting than useful.
PPS - But it is another stepping stone for AGI programmers getting into SCI.
Mokalus_of_Borg I've upgraded vew2vew to version 1.1.1b, with the following changes:
- Handles mirroring properly now.
- Removed the prompt for a keypress to exit from command-line argument mode.

Mokalus of Borg

PS - I'm more pleased with the quality of this converter than the others.
PPS - Without any bug reports or comments, I'll call it the full version in about a week.
AGI1122 I have not even tried it out yet. I will give you a bug report(if any) after I play around with it a bit.
Mokalus_of_Borg Thanks. I'm 99% sure there aren't any bugs, since it successfully converted the entire set of views from SQ2. But it always pays to have someone else put the code through its paces.

Mokalus of Borg

PS - I'll get to work on snd2snd next.
PPS - That could take a while.
AGI1122 I will test it with the views from V since it has big and little views. That way you can be sure that it will work with all sizes of views.
AGI1122 I tried it with 3 views just now. It seems to have problems with the bigger views, they are all distorted and you can't really see what they are. Plus in the viewer for the views all the numbers of cels where screwed up. The big ones really give it trouble. The regular ego views and things like that worked perfectly though.
Mokalus_of_Borg Just released is version 1.1.2b, which works perfectly on everything I've tested it on. Wide views are no problem anymore, and I never saw that view number screwup after public release - could you tell me more about it?

Mokalus of Borg

PS - There's a minor problem with the standalone executable.
PPS - But the uncompiled script works fine.
AGI1122 The problem happened with the biggest ship that is in the V game I beleive it is view 50 or 51. Well after I turned it into an SCI view I loaded the view up it was blank nothing was drawn and all the cel and loop numbers where screwed up with weird negative numbers. I will see if the same thing happens with this new version.
... it was blank nothing was drawn ...

That's the minor problem with the Win32 executable. I don't know what's caused it, and I don't think I can fix it. I'll go over to some Python boards and ask around, as well as comparing script & exe output here. I'll try everything in my power to get on top of it, but this part of the problem might go away if you use the script version.

... all the cel and loop numbers where screwed up with weird negative numbers ...

That's a new one on me. I've tested lots of views, and I've never seen negative numbers. It could be an SCI Studio bug, though.

Mokalus of Borg

PS - Thanks for the feedback.
PPS - It's the beta-testers that keep programmers honest.
AGI1122 It wasn't SCI Studio that I was using to view these things with. I am using SCI Graphic Studio which is a little less buggy than SCI Studio. But of course SCI Graphic Studio only deals with graphics which means no programming and no sounds.
sonneveld are you sure it's not this graphics studio that's causing the bug?

- Nick
Mokalus_of_Borg I did find a bug that caused problems converting that particular view, and any others wider than 128 pixels. (Check the file size of the problematic converted view - it's probably only 14 bytes long).

So anyway, that's fixed now, and version 1.1.3b is now available.

Mokalus of Borg

PS - Let me know if any more problems crop up.
PPS - I think I'm at least close to a bugfree release, though.
are you sure it's not this graphics studio that's causing the bug?
I don't beleive so because I have never ran into a bug while using SCI Graphic Studio, of course I ran into thousands of bugs while using SCI Studio.

Alright I will check out the new version. :)