Is there any chance of getting my game back?

FastaKilla Hi. I was programming some things in the script and did something stupid. There is a line of code in rm1 that says


I accidentally typed

(self:setScript(RoomScript)) the line after

(instance RoomScript of Script
   (method (handleEvent pEvent)
and I compiled the script. It said successful, then I read through it and realized the mistake, deleted the line
but when I tried to compile, it said there was an extremely rare error or something. Now the game doesn't work and SCI Studio won't open it. Is it screwed up forever or do I have a chance to get it back? (I have a 283 kB zip file of the game if anyone wants to mess with it).

Luckily I hadn't started too much of the game, just like 16 or so pics, 16 or so views, 14 sound files, and just a little scripting.
Brian_Provinciano SCI Studio 3 checks if games are valid to load them. SCI Graphic Studio 1.5 does not. Try extracting your resource though that.
FastaKilla It still won't work. Is the permanately screwed? :-
Brian_Provinciano I'll code up a program which will obtain all the files from the resource.000 file and rebuild a file for you. Should have it ready for you by tomorrow.

Don't worry ;)
mr-t The same thing happened to me all the time (back in teh olden days of SCI Studio 2.0)
Mr.Money Hey,
I think I encountered a similar problem. I tried using DrawPic, but I accidentally compiled it with a pic number that didnt exist. And now I can open the game at all.
What should I do?
Wilco23 Put your head between your legs and cluck like a chicken.
FastaKilla Wow Thanks!
I just had to make a copy of respack.tmp and rename it to resource.001 (if anyone else is having trouble).
Mr.Money Sweet that worked for me, thanks
FastaKilla wrote:

Wow Thanks!

That's ok, I'm just glad to help :)
mr-t I might have a chance of getting my one-year-old project back now. If SCI Studio 2.0 code still works with SCI Studio 3, that is...