Can't complete KQ5!!

Patrik Aargh!! I've been having a very annoying problem for quite some time now, wonder if anybody can help. I do own the old dos version of Kq5 and I can't see the ending sequence! After I've turned Mordak out with water, King Graham automatically goes to turn his family back to normal, which doesn't work - then princess Cassima comes into the room saying some stuff and when she says "There's got to be a way etc etc" the textbox simply won't go away. I can tell that the game hasn't completely hung because the water (or whatever it is) to the right is still "moving". I thought it was a cycling (or slowdown) prob but not even Dosbox, which solved the nasty cycling probs in Sq4 very neatly, works... Anybody knows how to solve it?
Lightfoot I couldn't finish it either, the colors went all wacked and no matter what I did, it wouldn't follow through the ending sequence.
Patrik Okay, but are you also talking about the dos version? I was kinda wondering if the win version (from the KQ collection) might work, as my Sq4win version worked a little better than the dos version... But then again it doen't even have to be the same kind of problem. If anybody have managed to go through the dos version AND see the ending seq I'd like to hear about it, because it might mean that mine has somehow gotten corrupt or something. I don't know. But it seems like were talking about the same kind of problem, Lightfoot, as I recall that the colors went all weird a couple of times when I tried it.
rwfromxenon Same Here,
I never saw the ending to KQ5. :'(
The game just crashed and i haven't played it since.
(1999... long time...)
MusicallyInspired I have the EGA disk/dos version and the ending sequence works fine for me. dont know what to tell ya.
Patrik Well, mine is the VGA disk version. I've never seen the EGA version (except on the Amiga, I guess it's the same version or am I wrong?). I think this sucks, it seems like there are some other people who're having the same kind of problem as I do, so there's probably nothing wrong with my copy. Why the heck haven't Sierra released a patch for this? The patches available at Sierra's web site doesn't seem to deal with this at all... There is a patch containing a savegame which puts you just BEFORE this point. But that doesn't help me as I do have my OWN savegame from that point, but I can't go any FURTHER! Sometimes I feel like punching some Sierra employee on the nose, but it probably wouldn't help much... Anybody know where I can BUY this EGA version? Is it included on the KQcol CD? If it can't be bought, may I ask if it can be downloaded somewhere? Of course I'd prefer buying it...