Annoying problem with "W"-words...

lemur Hi all,
This will probably sound stupid and odd to you:

I'm new to this AGI-dev stuff and I'm eating my fridge in frustration over a strange thing. I can't seem to add words beginning with "w" to the words.tok - file. The interpreter doesn't recognize them. I can add whatever other words I like except for "w"-words. Kinda annoying since I wanna have a "wallet" in my game :).

I use AGI Studio 1.35. Anyone came across this problem before? I've tried other fanmade games and there it works fine. I can't find anything I do wrong. Help! :)
Parabola not a solution, just a thought. what about having the wallet as the inventory screen and carried objects are put in the 'wallet'? :-\
CapTAmerik@ Maybe you could use a 'money clip' (if you use the wallet for money)?

Or maybe a 'business card holder' when you use it for business cards?

Rainer I think that kinda defeats the purpose. The problem is still there. what if he wanted wand? or willow, or wasp?
mr-t I agree with Rainer. What's the point of making a solution to a problem that will still be there?
CapTAmerik@ I'm not saying I possess the knowledge. I'd be one of the worst when it would come to giving you a programming solution to the whole W in .tok...

So I was just trying to come up with a creative solution, as I'm sure there are other words for 'wand', 'wasp' and 'willow' as well.

The point I'm making is this: if no one knows the problem exists, or no one knows how to deal with it, avoid it when making your game concept!



mr-t Sorry for being a total bitch, but shouldn't we concentrate on finding a solution?
lemur I've got all kinds of synonyms for the wallet. Like cash / money / billfold / etc... The strange thing is this, my code:

if (said("look","wallet")

And I write: "look wallet" I get an error: "logged an unknown word".

But if I write: "look cash" everything works fine! "Wallet" and "Cash" are in the same wordgroup:

billfold | cash | money | wallet

and the code says "look","wallet" (above) but still I can't use that word, but the other words in the same group?!?! strange isn't it? I noticed yesterday that some words work. Words that don't get recognized: war, walls, wallet, water. Words that get: woman, word, wuzz.

I've tried to take away the debug stuff but then I'll get the game-error, unrecognized word bla bla bla, instead which is pretty much the same :-)

Thanks for trying to help!
mr-t No problem, lemur ;)
AGI1122 Be sure to recompile your script after you alter the word list, if you don't recompile it then it won't know that the word exists(and give you the error).

That is the only time I have ever had that error before... so if that isn't it then I am not sure what is. Try what Chris said.

lemur wrote:
Words that don't get recognized: war, walls, wallet, water. Words that get: woman, word, wuzz.

Looks to be only words starting with wa.
lemur Chris: Yes I've recompiled all the scripts. Besides, the interpreter recognizes words that I've added AFTER the word "wallet". Would be great if someone had time to test this on their machine.

It's words that start with "wa", "wb" and "wc" aswell. Haven't tried how far up it goes, but "wo" works fine.
jelleghys Send it to me... And I'll try to find out what's wrong with it...
lemur Jelle: Sure I could do that! But I meant if someone could just try to add the word "wallet" to their words.tok-file and see if the game understands it. Just a dumb-check to make sure there's no bug hidden somewhere...
jelleghys Oh sorry.

I have some W-words in my game: watch, who,... and they all work!
David Smith I'm sure this isn't it, but sometimes it's the little things. Are you sure that you didn't put a space before or after the word in the words.tok file. I did that once and it didn't work until I removed the space.
lemur Thanks David and yes, I've made sure there are no spaces before or after the words.
Joel I have some w words in my game (including some "wa" words), and they all work without any problems.

Have you tried deleting the problem word and then re-adding it?
lemur Joel: Yes I have, hundreds of times! :-) I don't know how this works, but could it be a problem with the specific version of AGI-interpreter I'm using?

I'm using v2.936.
Kon-Tiki I'm using v2.936 too, but it works fine (the word 'wall').

mr-t Maybe you should switch to SCI. It doesn't discriminate against the letter "W" like your AGI does.
Joel It probably is not the interpreter version, but I can't say that for certain. If you're using the interpreter packaged with the template game that comes with the latest versions of AGI Studio, I'd recommend at least trying a different interpreter if not using another one all the time (as far as I can tell, sound doesn't work in the interpreter packaged with the template's a hacked version 2.936 unhacked 2.936 interpreter is available at

The only other thing I can think to do is as was previously suggested. Post the words.tok file or send it to someone to look at it.
nio Hello! I think it depends on the agi-studio version you are using. just try an other version.
Joel also, have you tried running the game with NAGI?
sonneveld lemur:
make sure the problem still exists and then could you email the files to ?

I'll have a look

- Nick
lemur Thanks Nick, I'll do that!
sonneveld I've found the problem, some bug make agi studio put the words in the wrong order (they need to be alphabetical) and the index was wrong also because of it.

Quick fix: delete wallet and enter it again. I used AGI Studio 1.36.


- Nick
Oliver I've got the same problem (I just make the wallet a money bag)
lemur Oliver: Yes, but if you wanna make a good game, or at least a decent one, the interpreter should understand obvious synonyms like "money bag"-"wallet". I think so anyway.

And the quickfix Nick suggested doesn't work for me.

Today as I was working in harmony with my game I got the same problem with the word "van". This is really shitty. The mother is extending!!! :-)

Could someone with some extra time on their hands write a quick and dirty tool that simply sorts the words inside the words.tok-file correctly?
Joel Just a question regarding the quick fix -- did you save the WORDS.TOK file after deleting the word?

If not, try doing that. Delete the word. Save. Add the word. Save again. That may take care of it.
sonneveld I could probably whip up a sorting tool but I'm still interested in fixing the original problem in agi studio.

- Nick
Robin_Gravel I see no problem with ws but I still use agi studio 1.31.

Robin Gravel
rwfromxenon Will it work with other versions of AGI Studio or is this happening on all of them?

I see no problem with ws but I still use agi studio 1.31.

Same here.
thesam I had the same problem with a game I was working on, but it worked when I resaved the WORDS.TOK in the Windows port of the Linux AGI Studio, and later I found out that it worked with nailheads AGI Studio too. I believed it had something to do with my Swedish version of Windows 98, since everyone else was using the English one, and the Swedes I spoke with (the guys working on Lawman for hire)had the same problem.

Still visiting this place from time to time
lemur Joel: Yeah, I did. before, after, during, between. I really hate this bug and I even consider giving up the AGI-programming just in protest!!!! :-)
sonneveld who else has a different language version of Windows AND has or had problems with AGI Studio?

- Nick
lemur I use a swedish Windows 98 aswell. Maybe that's it then...