Background picture never loads... ?

C-16 Ok I got a background picture that never loads everytime I run the game. It just freezes at the intro scene giving me the hand/waiting cursor. I have tried replacing this picture with other pictures and it works just fine whenever I do so. However, when I replace it with this picture, the scene doesn't load. It is 27kb. I can edit it and view it just fine in SCI Studio, so I don't see what the problem is. Is there some kind of picture file size limit that I don't know about?
jonnings I've experienced the same problem. But only if i replace the empty default pic. :P
C-16 Yes, that's it. That's the problem. And I've been experimenting with it a little and I've discovered something most odd. When it's at 15kb it puts the picture on the bottom of the screen so that you can only see the very top of the picture. It also takes a few seconds before it does this. It is really odd.

Joe Check to make sure there aren't any files of the same name in the game's directory. You might also want to do a 'Rebuild Resources'. Good luck
Brian_Provinciano You shouldn't change the picture that is used in between scenes. It's there for a reason.

Also, the only time my game has frozen like this is when you try to load a pic that doesn't exist, yet the interpreter doesn't give a file not found error, it just freezes.

Finally, like I said, keep the game free of loose files.
C-16 uhh loose files? I'm kind of new and I guess I'll have to read the tutorial but -- what do mean by loose files? I'll be sure I don't have any of that (whatever it is) and I think the problem is that the picture size is too big because whenever I go a couple steps back in the picture and crop, the file size reduces, therefore allowing the game to work. So, now I'm trying to download PCX2RAW2PIC to fix this problem but I can't seem to download it.
Brian_Provinciano leave the loading picture (between rooms) as it is, don't modify it! Other pictures can be up to about 64K.

Loose files are what I told you about earlier, like view.000 or script.200 in the same directory as resource.001.

Finally, you haven't done the tutorial!? No wonder you're asking questions left and right! Please do it from top to bottom and don't skip anything. Then, go through part two. You should be quite questionless.
Steven Melenchuk Hmm... I've seen this problem too. It tends to go away if your picture sizes are less than around 20kb.

Really large views tend to crash the game, too...
Lars Skovlund Have you tried a later interpreter, such as 0.000.685? The one that comes with SCI Studio is 0.000.629, IIRC.
I'd say this was a bug they would fix quickly.
Please note that I am not sure about this at all, it's just a suggestion.
(*chuckle* I now see that QfG2 - SCI01 - has a pic that's 38K in size.
Of course, that interpreter supports those embedded view thingies. That accounts for the large size)
Lars Skovlund ...and of course, if it's important, you could kludge your way around it by using the overlay capability of the interpreter.
That's how the attic in CB1 is done (though with a different purpose).
Brian_Provinciano I guess for the next version I'll include a newer interpreter. However, I can't really see pictures being more than 20K if you are drawing them, and not just converting bitmaps. LSL3, Hero's Quest and SQ3, for example, has really detailed pictures, and none of them are too big.
Steven Melenchuk Some statistics, to expand on Brian:

SQ3's largest picture is 12.7K.
LSL3's largest picture is 9.47K.
QFG1's largest picture is 13.2K.

The largest picture drawn for SF1 so far is 1.23K.
The same picture converted with XToPic is 43.5K.

Compare those last two, and see what you can learn from that... ;)