0 users browsing Discussion. | 2 guests | 9 bots  
Main » Discussion » Board feature requests/suggestions
Pages: First Previous 13 14 15 16 17 18 19 Next Last
Posted on 19-09-05, 13:34
Confound these ponies, they drive me to drink.

Post: #387 of 480
Since: 10-29-18

Last post: 1 day
Last view: 2 hours
Posted by CaptainJistuce
Posted by Nicholas Steel
I guess I shoulda made my comment about the Quote system here, in any case thanks for adjusting the Quote visuals to make it easier to see who said what.

Here's a feature request: Add a "Cancel" button when making posts and editing posts, the button should obviously take you back to the previously visited page.
Why not just alt-left? Or click the thread title above the reply/edit box? Or the back button in the address bar?
I mean, that's what the back button in the address bar is for, isn't it? To take you back to the previously visited page? It's not like this thing is rife with weird history-clobbering dynamic content changes or whatnot that could prevent this basic feature from working properly, unlike some sites I'm sure we could all mention.
Posted on 19-09-05, 19:08
Post: #85 of 136
Since: 11-01-18

Last post: 9 days
Last view: 4 hours
How dare you assume the existence of UI elements!
Posted on 19-09-05, 20:18
Stirrer of Shit
Post: #617 of 717
Since: 01-26-19

Last post: 74 days
Last view: 72 days
Even if you don't, you can still just hit the thread topic to go back.

There was a certain photograph about which you had a hallucination. You believed that you had actually held it in your hands. It was a photograph something like this.
Posted on 19-09-05, 20:19
Universally genre savvy

Post: #389 of 480
Since: 10-29-18

Last post: 1 day
Last view: 2 hours
Or press Alt-Left.
Posted on 19-09-05, 20:27
Custom title here

Post: #676 of 866
Since: 10-30-18

Last post: 2 days
Last view: 15 hours
Is there an echo in here?

--- In UTF-16, where available. ---
Posted on 19-09-05, 21:00
Has a random title and you don't

Post: #390 of 480
Since: 10-29-18

Last post: 1 day
Last view: 2 hours
Nah, I was just fishing for a how dare you assume the existence of a keyboard.
Posted on 19-09-06, 00:23
Post: #86 of 136
Since: 11-01-18

Last post: 9 days
Last view: 4 hours
how dare you assume the presence of a specific class of human interface device!
Posted on 19-09-06, 04:32 (revision 1)
Custom title here

Post: #677 of 866
Since: 10-30-18

Last post: 2 days
Last view: 15 hours
How dare you buttume!

--- In UTF-16, where available. ---
Posted on 19-09-22, 20:21 (revision 1)
Post: #19 of 25
Since: 12-10-18

Last post: 197 days
Last view: 197 days
I think I may have mentioned this before but it might be worth adding a CSS media query and classes that stops certain things appearing on mobile devices to some things like the post helper (looks kinda ugh on my end tbh), as well as forcing some non-100% widths to 100% where necessary like the registration page form’s table (mainly so it isn’t squashed). I can test those changes on both an iPhone SE and an Xperia Z5, as well as give some advice on that. :)

For consistency also, some of the input fields (like the post input text area) are for some reason bigger width than the actual box on mobile. Dunno what it is like on desktop but it might also look slightly off, idk.

While no one is probably using this board on a mobile device the thought would be nice to have there (I personally am and might actually start posting here again for some reason every now and then, would make things easier if it was more usable without having to mess with desktop much. It’s possible, I’ve managed to adapt the layout before with this software so...)

Oh.
Posted on 19-10-01, 22:29
Stirrer of Shit
Post: #653 of 717
Since: 01-26-19

Last post: 74 days
Last view: 72 days
What happened to the posting form? It looks all odd and the user fields are gone.

There was a certain photograph about which you had a hallucination. You believed that you had actually held it in your hands. It was a photograph something like this.
Posted on 19-10-01, 23:08
Is gonna need more trope

Post: #417 of 480
Since: 10-29-18

Last post: 1 day
Last view: 2 hours
What do you mean "odd"? It was all squished onto the side on mobile and the user fields were inconsistent. Now it's as wide as it gets on both media and the fields are just not there at all anywhere.
Posted on 19-12-19, 07:37
Post: #316 of 353
Since: 10-30-18

Last post: 1 day
Last view: 7 min.
User is online
Does the forum automatically lock topics? I was gonna mention Nvidia's upcoming release of PhysX v5.0 here https://helmet.kafuka.org/bboard/thread.php?id=42 but the topic is locked for seemingly no reason?

AMD Ryzen 3700X | MSI Gamer Geforce 1070Ti 8GB | 16GB 3600MHz DDR4 RAM | ASUS Crosshair VIII Hero (WiFi) Motherboard | Windows 10 x64
Posted on 19-12-19, 11:04
I found Forrester and all I got was a random title

Post: #454 of 480
Since: 10-29-18

Last post: 1 day
Last view: 2 hours
Ah yeah that's a feature where old threads get a warning on the newreply page about bumping it, and really old ones get autolocked. It's set to six and twelve months respectively. Let me just change that to six and 999 and unlock it for ya.
Posted on 19-12-19, 23:10
Custom title here

Post: #794 of 866
Since: 10-30-18

Last post: 2 days
Last view: 15 hours
Posted by Kawa
Ah yeah that's a feature where old threads get a warning on the newreply page about bumping it, and really old ones get autolocked. It's set to six and twelve months respectively. Let me just change that to six and 999 and unlock it for ya.
But what if I REALLY NEED to bump an 84-year-old thread?

--- In UTF-16, where available. ---
Posted on 19-12-20, 01:31
Stirrer of Shit
Post: #695 of 717
Since: 01-26-19

Last post: 74 days
Last view: 72 days
A solution some forums use is to put old threads on "autosage". That is, you can still post in them, but they won't get bumped. So your very interesting discussion about Netscape can go on for all eternity, but it won't be hot news for long. This also works for culling megathreads, forcing them to keep to a manageable size and re-summarize the old news for the newcomers.

There was a certain photograph about which you had a hallucination. You believed that you had actually held it in your hands. It was a photograph something like this.
Posted on 19-12-20, 05:28
Custom title here

Post: #795 of 866
Since: 10-30-18

Last post: 2 days
Last view: 15 hours
That's dumb.

--- In UTF-16, where available. ---
Posted on 19-12-20, 12:41
Secretly, I'm William Shatner

Post: #455 of 480
Since: 10-29-18

Last post: 1 day
Last view: 2 hours
And the way the thread list is sorted to begin with wouldn't allow it. This is not a trivial change.
Posted on 19-12-20, 16:07
Stirrer of Shit
Post: #697 of 717
Since: 01-26-19

Last post: 74 days
Last view: 72 days
Well, I'm not suggesting it here, because this forum is in my opinion too small to warrant such restrictions anyway. But is it really? Looking at the code on GitHub, it seems like you sort by lastpostdate, which is on the thread/board and not the last post in it. I would just think you need to change this part so that there's a condition to updating lastpostdate:
          $rFora = Query("update {forums} set numposts=numposts+1, lastpostdate={0}, lastpostuser={1}, lastpostid={2} where id={3} limit 1",
$now, $loguserid, $pid, $fid);

$rThreads = Query("update {threads} set lastposter={0}, lastpostdate={1}, replies=replies+1, lastpostid={2}".$mod." where id={3} limit 1",
$loguserid, $now, $pid, $tid);

And the same for editing posts.

Of course, if you've changed it to do a join or something, all dice are off the table.

There was a certain photograph about which you had a hallucination. You believed that you had actually held it in your hands. It was a photograph something like this.
Posted on 20-03-27, 20:47
Not from my cellphone

Post: #654 of 664
Since: 10-30-18

Last post: 4 days
Last view: 3 hours
So, apparently commie telco is blocking me from accessing the bBoards.

Or not, looks like Movilnet is trying to go through a broken route:
traceroute to helmet.kafuka.org (151.236.14.55), 30 hops max, 60 byte packets
1 saki.tomman.net.ve (192.168.0.254) 0.955 ms 1.280 ms 1.685 ms
2 * * *
3 10.24.240.102 (10.24.240.102) 72.750 ms 72.781 ms 82.010 ms
4 10.24.240.73 (10.24.240.73) 112.635 ms 112.669 ms 112.958 ms
5 10.24.240.68 (10.24.240.68) 102.218 ms 102.614 ms 122.544 ms
6 10.24.240.54 (10.24.240.54) 122.920 ms 109.820 ms 109.713 ms
7 10.150.165.1 (10.150.165.1) 128.560 ms 69.934 ms 79.612 ms
8 10.82.1.1 (10.82.1.1) 70.429 ms 80.912 ms 80.669 ms
9 globenet-177.as52320.net (200.16.71.177) 189.518 ms * 189.280 ms
10 * * *
11 * * *
12 * * *
13 * * *
14 * * *
15 * * *
(snipped 16-30 dead hops)

Apparently it chokes as soon at it leaves Movilnet/CANTV routers, at the first external node, which is operated by GlobeNet, and is supposedly located at Bogota, Colombia. So it's either a broken cable somewhere else, or good ol' Maduro playing hardball with its motherland Colombia.

However, I've plugged my Movistar 3G shitphone, where I can connect successfully:
traceroute to helmet.kafuka.org (151.236.14.55), 30 hops max, 60 byte packets
1 saki.tomman.net.ve (192.168.0.254) 0.941 ms 1.186 ms 1.563 ms
2 * * *
3 10.53.37.49 (10.53.37.49) 766.776 ms 766.836 ms 767.929 ms
4 10.53.128.9 (10.53.128.9) 767.382 ms 784.658 ms 784.908 ms
5 10.53.242.49 (10.53.242.49) 836.409 ms 836.705 ms 839.447 ms
6 10.19.112.2 (10.19.112.2) 836.682 ms 825.721 ms 825.932 ms
7 * * *
8 10.19.3.129 (10.19.3.129) 199.145 ms 278.835 ms 264.309 ms
9 10.19.3.170 (10.19.3.170) 264.347 ms 212.761 ms 288.600 ms
10 10.19.3.165 (10.19.3.165) 290.437 ms 288.391 ms 288.152 ms
11 10.19.3.142 (10.19.3.142) 288.505 ms 249.507 ms 171.346 ms
12 * * *
13 ae1-300G.ar5.MIA1.gblx.net (67.17.94.249) 220.747 ms ae0-300G.ar5.MIA1.gblx.net (67.17.99.233) 218.951 ms ae1-300G.ar5.MIA1.gblx.net (67.17.94.249) 219.263 ms
14 * * *
15 * * *
16 centurylink1-eqx-am5.r2.dba.nl.as43350.com (213.244.134.227) 278.040 ms 760.729 ms centurylink1-eqx-am5.r1.dba.nl.as43350.com (213.244.134.226) 288.391 ms
17 55-14-236-151.static.edis.at (151.236.14.55) 279.664 ms 269.608 ms 380.711 ms

Note that Movistar goes through another route from another provider (this time it's Centurylink / Level 3, according to IP and WHOIS lookups)

Unfortunately I can't just switch to Movistar full-time, as their coverage is basically rubbish at home (3G is borderline, LTE is unusable), connections die after a few seconds, latency makes this look worse than POTS dial-up, and absurdly expensive to boot (compared to Movilnet, which is still crap, a latency minefield, has prolonged blackouts, AND it's commie-monitored/censored to hell and back, but at least it's more stable)

I hope that whoever said Internet routes around damage dies of COVID-19

The joys of not having a real Internet connection anymore, guys.

Licensed Pirate® since 2006, 100% Buttcoin™-free
Posted on 20-03-27, 21:55
Not from my cellphone

Post: #655 of 664
Since: 10-30-18

Last post: 4 days
Last view: 3 hours
Huh, it's now working?

traceroute to helmet.kafuka.org (151.236.14.55), 30 hops max, 60 byte packets
1 saki.tomman.net.ve (192.168.0.254) 0.873 ms 1.419 ms 1.757 ms
2 * * *
3 10.24.240.94 (10.24.240.94) 134.047 ms 143.217 ms 163.149 ms
4 10.24.240.74 (10.24.240.74) 174.130 ms 204.024 ms 216.274 ms
5 10.24.240.69 (10.24.240.69) 233.933 ms 244.060 ms 274.008 ms
6 10.24.240.50 (10.24.240.50) 283.712 ms 290.219 ms 299.951 ms
7 10.150.165.1 (10.150.165.1) 330.224 ms 219.727 ms 230.598 ms
8 10.82.1.1 (10.82.1.1) 220.421 ms 229.562 ms 269.595 ms
9 globenet-177.as52320.net (200.16.71.177) 397.386 ms * 419.569 ms
10 globenet-245.as52320.net (200.16.68.245) 415.167 ms * 409.815 ms
11 * * *
12 185.107.116.2 (185.107.116.2) 519.645 ms 519.552 ms 509.401 ms
13 55-14-236-151.static.edis.at (151.236.14.55) 459.393 ms * 319.343 ms


Fuck CANTV/Movilnet anyway, yo.

Licensed Pirate® since 2006, 100% Buttcoin™-free
Pages: First Previous 13 14 15 16 17 18 19 Next Last
Main » Discussion » Board feature requests/suggestions
Kawa's Github