Unable to download beat 
Author Message

Joined: 2017-09-28 20:16
Posts: 3
 Unable to download beat
I wasn't sure where to post this, so I apologize if this is the wrong forum...if so please let me know and I'll repost in the correct place.

I am trying to use a .bps file that is a translation patch for a gba rom. I'm trying to run the rom on VBA and it does not recognize the file .bps. I was recommended to use the program "beat" to patch the file.

I tried to download from this link: http://www.romhacking.net/utilities/893/
However, when I try to open the file, I get the error message "Incorrect command line" (I do have 7zip installed.)
So I tried to download the file from this url: https://byuu.org/tool/beat/
And I get a page which says 404 Not Found

Just wondering how to download this program to see if it works for my rom.
Thanks for any help.


2017-09-28 20:24
User avatar

Joined: 2014-10-29 21:24
Posts: 1814
Location: People's Republic of America
 Re: Unable to download beat
It might be best to use Floating IPS instead. Floating IPS's formula for creating delta patches is not quadratic, so it takes less time to create new patches. Also, beat is on hiatus for now.

_________________
bsnes-mcfly: A port of the Qt GUI from v073 to v106.
nSide: A higan fork w/NES boards and peripherals and Sonic & Knuckles Lock-On.
Dragon Quest I & II RPGOne Beran Inn bugfix


2017-09-28 21:19

Joined: 2017-09-28 20:16
Posts: 3
 Re: Unable to download beat
Thank you. Must I find a .ips version of the translation or will the Floating IPS be able to use a .bps file?


2017-09-28 22:54
User avatar

Joined: 2014-10-29 21:24
Posts: 1814
Location: People's Republic of America
 Re: Unable to download beat
Floating IPS supports both .ips and .bps.

I guess the program's name is slightly misleading, huh.

_________________
bsnes-mcfly: A port of the Qt GUI from v073 to v106.
nSide: A higan fork w/NES boards and peripherals and Sonic & Knuckles Lock-On.
Dragon Quest I & II RPGOne Beran Inn bugfix


2017-09-28 22:58
User avatar

Joined: 2014-09-27 09:56
Posts: 1688
 Re: Unable to download beat
It is my understanding that both the name and the UI of Floating IPS were intentionally similar to Lunar IPS to cater to those people out there who inexplicably hate change of any kind. Just in case you want any of the other old utilities that are dead links, I have them all mirrored here: viewtopic.php?f=20&t=1485#p36341 (however, in this case I also suggest the use of Floating IPS over beat).

_________________
byuu wrote:
Surely I can unite the vi vs emacs crowd like I have the ZSNES vs Snes9X crowd :)



higan WIP builds available here


2017-09-28 23:20

Joined: 2017-09-28 20:16
Posts: 3
 Re: Unable to download beat
Problem solved, thanks so much to all.


2017-09-28 23:43